之前是在windows里面跑vmware,把机器升到了24GB内存,但是后来慢慢也是比较卡了,要是能够跑在linux下面,该是多好呀。

deepin linux的软件仓库里面可以直接安装vmware 12, 但是运行后,需要使用gcc编译kernel,这个就比较扯淡了,而且当前deepin linux 15.03里面自带的内核已经

gcc version 6.2.0 20161103 (Debian 6.2.0-11)

这里写图片描述

先这样,拭目以待~!

作为一个系统管理员,平日里少不了测试打交道,而vmware对于测试来说非常重要。

这两天,尝试着在deepin 里面装vmware12,过程如下。

1. 从deepin store里面装vmware 12

  1. 安装完成之后,运行vmware 12 workstation
  2. 会提示要有 gcc-5.4.1
  3. 好吧,开始编译 ```

    其实下载到的也只是gcc5.4.0,进入目录,执行下面的命令,下载依赖,大概10分钟左右

    ./contrib/download_prerequisites

开始编译,大体上的命令参数如下

./configure --disable-multilib --prefix=/opt/5.4.0/ --build=x86_64-redhat-linux --enable-threads=posix

会遇到如下的问题,好吧,查了查,我也没有理会

checking whether to enable maintainer-specific portions of Makefiles... no

开始make

make -j 4

会遇到如下的错误,这个错误不理会就不行了,从网上查找,貌似编译的时候,gcc命令啥的问题,deepin默认gcc版本已经到了6了。

Makefile:25209: recipe for target 'stage1-bubble' failed

在命令行gcc然后tab,居然发现了gcc-5,尝试着将下面的命令打入vmware workstation执行安装,提示错误

/usr/bin/gcc-5

以为gcc-5就是个链接,想找到安装目录,不料发现原来下面的才是个链接,打入vmware workstation试试白,没想到成了。

/usr/bin/x86_64-linux-gnu-gcc-5

vmware workstation安装大概1分钟左右

输入license,ok搞定。

5A02H-AU243-TZJ49-GTC7K-3C61N ```

没想到里面已经了gcc5.4.1了哦

这里写图片描述

安装之后的界面截图

这里写图片描述

搞定~

Copyright © opschina.org 2017 with zzlyzq@gmail.com all right reserved,powered by Gitbook该文件修订时间: 2017-07-11 11:32:48

results matching ""

    No results matching ""